...

un color picker pour smf 2.0.14 ca se trouve ?

Démarré par fichtre, 01 septembre 2017 à 14:16:20

« précédent - suivant »
En bas

fichtre

Salut salut par ici!


J'aimerais avoir plus de choix dans les couleurs proposées par la barre d'édition dans smf, mais avec également un visuel de la couleur.
Mon forum ayant un fond gris foncé, le rendu n'est pas toujours propre et comme je n'utilise plus le WysIwyg par défaut parce que ca faisait trop d'erreurs dans les post niveau code, on ne peux pas se rendre compte avant d'avoir posté le dit message.


J'aimerais donc trouver un colorpicker comme le fait ce mod mais celui ci malheureusement n'est pas compatible et même en faisant une émuation j'ai des echecs d'install ...


Auriez vous une idée de 1) si ca existe encore et de 2) ou je peux trouver ca :)  ?


Merci a tous et bonne apreme

maximus23

Bonjour,

J'ai cela dans mes modules donc un peu de patience car là j'ai une grippe carabinée....

:)
Amitiés et à Bientôt.
Have a Nice Day.

fichtre

Merci, soigne toi bien :) Ce n'est pas pressant ^^

maximus23

Bonjour,

Fais un tour dans la section appropriée tu trouveras ce qu'il te faut :)
Amitiés et à Bientôt.
Have a Nice Day.

fichtre

bonjour :)


J'ai bien testé ton mod mais ca ne fonctionne pas vraiment. Merci tout de même ^^

maximus23

19 septembre 2017 à 11:49:51 #5 Dernière édition: 19 septembre 2017 à 11:51:42 par maximus23 »
Bonjour,

Que veux-tu dire ne fonctionne pas vraiment ? Moi cela fonctionne très bien et sans le moindre soucis.

Alors explique le soucis que tu as ce serait mieux pour tout le monde.

@Alex si tu peux tester en local aussi et me dire si il y a u  soucis ? merci

:)
Amitiés et à Bientôt.
Have a Nice Day.

alexetgus


maximus23

Amitiés et à Bientôt.
Have a Nice Day.

alexetgus

Ah ben voilà ! :)

Je regarde ça après manger et je te dis.
De toute façon, tu ne te couches pas de bonne heure, hein ? ;)

alexetgus

Effectivement, il y a plusieurs problèmes et le mod ne marche pas. :(

Ca commence à l'installation, le mod n'est pas compatible avec la V2.0.14
Quand tu cherches les scripts, tu cherches par exemple :
Code
<script type="text/javascript" src="', $settings['default_theme_url'], '/scripts/script.js?fin20"></script>


Le souci, c'est que SMF 2.0.14 a rendu les JS asynchrones en ajoutant un paramètre :
Code
<script type="text/javascript" src="', $settings['default_theme_url'], '/scripts/script.js?fin20 async="async"></script>

C'est une partie vite fait à corriger.

Ensuite, et là c'est le pire !
Le JS ne s'installe pas dans ./Themes/default/scripts/jscolor/ mais carrément dans ./Themes/default/
En plus, il ne s'appelle pas jscolor.js mais color.js ! Le script est donc introuvable.
Ca oblige à renommer le fichier et à le placer au bon endroit.

Rien n'est installé dans le thème Core même si c'est proposé. Pas de JS, juste le code :




Une fois que tout est réparé, la plus grosse surprise arrive, le mod ne marche pas est la page est réduite sur sa largeur.
Je crois que c'est ton CSS qui se marie mal avec le JS...




Les balises BBCode s'affichent bien si on clique, mais il n'y a pas de color picker...

Comme tu vois, tu as du boulot devant toi ! ;D

maximus23

Bonjour,

Je ne sais pas ce que j'ai foutu mais mauvais package du mod.

Donc nouvelle version corrigée : https://www.smf-fr.com/index.php?topic=200.0

Voilà si on peut tester merci.

Si on voit une modification à faire pour le thème Core me le noter je l'ajouterai car je ne l'ai pas installé pour le moment.

Merci.

:)
Amitiés et à Bientôt.
Have a Nice Day.

alexetgus

Je comprends mieux pourquoi Fichtre disait "J'ai bien testé ton mod mais ca ne fonctionne pas vraiment." ;D


T'était encore debout à presque 3 heures ? :o C'est de ma faute si tu fais des insomnies ? :P
Je regarde la nouvelle version et je te dis ça. Là, il faut que je file, mais je te dis en début d'après midi. ;)

alexetgus

Décidément, ton mod est récalcitrant.
Toujours pas de color picker. :-\




maximus23

Je crois que cela vient du thème core regarde un peu si il ne faut pas que tu mettes le répertoire /cbcolor dans scripts de ton thème core.

:)
Amitiés et à Bientôt.
Have a Nice Day.

alexetgus

C'est sur le thème par défaut que j'ai essayé.

Au fait, tu as encore oublié d'ajouter async="async" aux JS qui sont recherchés par le mod.

En haut