...

Mail pour Wampserver

Démarré par JCFM, 02 Mars 2022 à 18:35:13

« précédent - suivant »

JCFM

Bonsoir, Oto !
Tout d'abord, j'espère que tu vas bien et que tu fais attention à toi, cette saloperie de virus a touché deux de mes amis et cela ne se passe pas bien, en réanimation à l'hôpital, cela me file des boules.
Une petite question sur Wamp.
Il y a quelque temps, je pouvais faire des essais d'envoi de courriels, j'avais configuré le fichier PHP. ini à cet effet.
Et puis, j'ignore pourquoi cette possibilité n'a plus fonctionné.
J'ai effectué les mêmes modifications, mais rien à faire.
Bien sûr, aucun problème chez l'hébergeur.
Tu as une idée, car c'est quand même pratique.
Cordialement.
Jean-Claude
JCFM

maximus23

Bonsoir JC,

J'espère que cela va aller pour tes amis.
D'après les autorités le virus maintenant n'existe plus !!!
Moi je l'ai eu il y a plus d'un an au début et j'en ai eu pour 6 semaines à m'en remettre mais j'en ai gardé pas mal de séquelles.

Pour Wamp et sa gestion mail regarde ici : https://www.smf-fr.com/index.php?topic=71.0

Si tu n'as pas de configuration smtp sur ton logiciel alors tu as la configuration et les fichiers nécessaires pour que tout se passe en smtp via WampServer.

Bonne fin de soirée.

:)

Amitiés et à Bientôt.
Have a Nice Day.
Developer Aestan Tray Menu for WampServer

JCFM

Bonsoir, Max.
Merci pour la promptitude de ta réponse.
Bah oui vaccinés mais pas de masque, une soirée entre amis et patatras.
Apparemment, le virus ignore ce que les autorités pensent !
Dans mon petit patelin, ou au début de la pandémie on n'était pratiquement pas concerné, cela tombe comme des mouches, même la secrétaire et la doctoresse qui m'ont fait mon troisième vaccin a été touchée.
Plus récemment, c'est mon voisin qui est touché, lui aussi, en réanimation.
Alors, les autorités !!!!!!
Je regarderai demain pour mon problème de courriels.
Bonne fin de soirée.
Jean-Claude
JCFM

JCFM


JCFM

Bonjour, Max.
Je m'y suis pris comme un manche pour envoyer les copies et le texte en même temps, désolé, 80 piges et je commence à trembler, lol.
Cela fonctionnait il y a encore quelque temps, il y a cinq ou six ans quand j'ai commencé avec  Wamp, aucun souci.
Bon, ce n'est pas bien grave, je peux effectuer mes essais sur mes sites à partir de l'hébergeur, mais je voulais comprendre.
Je ne suis pas un champion, je crois que tu l'as facilement compris, j'ai démarré en 2015, auparavant le PC, c'était pour la facturation, le fichier clients, hormis cela, je n'étais pas franchement intéressé.
Donc désolé si j'ai quelques lacunes.
Cordialement.
JC
JCFM

alexetgus

Sur le port 25, y a peu de chances que ça marche.

Essaye sur le port 587 en TLS :
Code
smtp_port=587

; SMTPS (SSL) support
;   auto = use SSL for port 465, otherwise try to use TLS
;   ssl  = alway use SSL
;   tls  = always use TLS
;   none = never try to use SSL

smtp_ssl=auto

alexetgus

J'ai oublié un truc, le chemin ne va pas.
Code
; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
; http://php.net/sendmail-path
sendmail_path = "C:/wamp64/sendmail/sendmail.exe -t"
Et bien entendu, ça doit se trouver dans le PHP.ini

Otomatic

Bonjour,

Et puis, les envois et réception d'email, via Free, ça merdouille sans arrêt.

Il suffit de lire le groupe de discussions Usenet "proxad.free.services.messagerie" pour s'en rendre compte.
Même si j'y ai quatre adresses email, il y a longtemps que j'ai arrêté d'utiliser la messagerie Free :(

alexetgus

Avec une adresse GMail ça devrait fonctionner. C'est ce que je faisais à l'époque quand mon domaine n'était pas connu et que quasiment tout passait en spam.
Par contre, chez Google il faut utiliser le port 465 en SSL. (si le choix de port est en "auto", on est bon)

Le mieux, pour savoir ce qui se passe, c'est d'activer les logs :
Code
; log smtp errors to error.log (defaults to same directory as sendmail.exe)
; uncomment to enable logging

error_logfile=C:/wamp64/logs/mail.log
Si un mail n'arrive pas à destination, il suffit d'ouvrir ce fichier. Le problème rencontré s'y trouve la plupart du temps.

JCFM

Citation de: Otomatic le 04 Mars 2022 à 09:44:37Bonjour,
Et puis, les envois et réception d'email, via Free, ça merdouille sans arrêt.
Il suffit de lire le groupe de discussions Usenet "proxad.free.services.messagerie" pour s'en rendre compte.
Même si j'y ai quatre adresses email, il y a longtemps que j'ai arrêté d'utiliser la messagerie Free :(
Bonjour, Oto.
Je suis chez Free depuis de longues années, et je peux te garantir que je n'ai aucun souci avec la quinzaine d'adresses courriel que j'ai.
Certaines sont très anciennes, je les conserve, s'est-on jamais, si un ancien client se rappelle qui me doit de l'argent ! Mort de rire. Bah non, je ne reçois que la pub.
Celles-ci sont gérées uniquement avec « opéra mail », certes, cette application est ancienne, mais fonctionne toujours et très bien avec Windows 10, configuré en« Imap » et non pas en »pop ».
Mes adresses courriel en, Hotmail, Outlook, Yahoo, Neuf, avec « Thunderbird », aucun souci non plus, et j'en ai, lol, chacune ayant une utilité bien définie.
Et enfin, « Foxmail » la version 6.5 que j'utilise avec toutes les adresses « Gmail », destinées aux administrations et à la famille & amie.
Malheureusement, cette version ne sera plus utilisable en mai, j'ai reçu un mail à cet effet de Google avant-hier.
Pourtant, la plus pratique, courriels paramétrables et surtout, tous les échanges, les sauvegardes, étaient stockés sur le disque de données.
Je n'ai pas encore trouvé son remplaçant. Et je fais la gueule ! Lol
Quant au problème des courriels avec Wamp, je n'ai pas trouvé la solution, mais je sais pourquoi.
Je m'explique dans le post de Max.
Cordialement.
JC
JCFM

JCFM

Bonjour, Max.
Je suis désolé pour le retard de ma réponse, j'ai passé pas mal de temps à essayer de trouver la solution.
 Comme je ne suis « qu'un bricoleur », bien obligé de tout essayer en piochant à droite à gauche sur la toile les « tuyaux », concernant le paramétrage des fichiers .ini.

Tu as raison, c'est bien (sendmail_path = "C:/wamp64/sendmail/sendmail.exe -t"), j'avais fait un copier-coller de ce que j'ai trouvé de plus récent sur la toile.
J'ai donc redémarré par un début en créant un « local host » avec Wamp, j'ai bien entendu ensuite, j'ai installé Wordpress et j'ai créé un site.
Rien de plus facile, et comme tu peux le constater, à la fin de l'installation, Wordpress demande une adresse mail.
Logiquement, je dois recevoir, confirmation de la création du site dans la boîte courrielle que j'ai désignée.
Chez l'hébergeur cela fonctionne très bien.
Avec Wamp, « sendmail » configuré correctement ainsi que le fichier PHP.ini, aucune nouvelle de ton inscription.
Cela fonctionnait très bien il y a encore deux ans et voulions en avoir le cœur net.
J'ai donc récupéré un ancien disque et je l'ai installé dans un ancien PC portable que j'ai.
Il est en Windows 7, il y a Wamp de l'époque, bien entendu sendmail ainsi que Wordpress version 4.9.
L'envoi de courriels fonctionne.
Ce problème provient de Wordpress depuis la génération 5.
Pourquoi cela fonctionne avec l'hébergeur et non pas avec wamp, là, cela dépasse mes compétences qui sont très minimes.
Bon, ce n'est pas grave, je peux bosser depuis l'hébergeur, bientôt 80 piges et un peu gaga, je voulais comprendre, mais bon.

Cordialement.
JC
JCFM

JCFM

Citation de: alexetgus le 04 Mars 2022 à 10:03:47Avec une adresse GMail ça devrait fonctionner. C'est ce que je faisais à l'époque quand mon domaine n'était pas connu et que quasiment tout passait en spam.
Par contre, chez Google il faut utiliser le port 465 en SSL. (si le choix de port est en "auto", on est bon)
Le mieux, pour savoir ce qui se passe, c'est d'activer les logs :
Code
; log smtp errors to error.log (defaults to same directory as sendmail.exe)
; uncomment to enable logging
error_logfile=C:/wamp64/logs/mail.log
Si un mail n'arrive pas à destination, il suffit d'ouvrir ce fichier. Le problème rencontré s'y trouve la plupart du temps.
Bonjour,
Je vous remercie pour votre intervention, mais comme je l'indique à « Oto », j'utilise « Gmail » pour les courriels administratifs, la famille et les amis.
Avec les mesures draconiennes, de sécurité que met en place Google, je ne suis pas persuadé que la fonction que vous me décrivez soit encore possible fin mai, c'est une supposition, je ne suis pas assez calé pour émettre une affirmation.
La fonction courriel fonctionne avec Wordpress chez l'hébergeur et j'utilise à cet effet les adresses courriel que j'ai créées chez eux à cet effet.
JC

JCFM

alexetgus

Si ça marche avec un vieux Wamp, récupère le dossier Sendmail de ce vieux Wamp et place le dans le nouveau en remplaçant tous les fichiers.

Ce n'est pas de la faute de Wamp si ça ne marche pas. Wamp est un serveur HTTP, pas un serveur SMTP.

Bien entendu, il ne faut pas oublier le PHP.ini :
Code
; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
; http://php.net/sendmail-path
sendmail_path = "C:/wamp64/sendmail/sendmail.exe -t"

En tout cas, il ne faut jamais utiliser le port 25 !
C'est le port utilisé par tous les spammeurs de la planète...

maximus23

Bonjour,

Le problème c'est les nouvelles règles d'authentification que Google Gmail et autres vont mettre en place.

L'authentification va se faire via YubiKey ou autre en utilisant le protocole Fido2. Donc ce sera une clé à deux facteurs d'authentification et les mots de passe seront supprimés.

Maintenant comment Outlook ou autres vont le reconnaître aucune idées et pas trop d'infos sur le net.

Si quelqu'un à des infos pour Office mode entreprise il est le bienvenu.

Pour ceux qui utilisent office 365 par abonnement là c'est déjà prévu.

:)
Amitiés et à Bientôt.
Have a Nice Day.
Developer Aestan Tray Menu for WampServer

alexetgus

#14
Il est possible d'utiliser Google d'une autre façon avec une authentification simple.
Cela s'appelle "Les mots de passe d'applications". C'est ce que j'utilise pour mon Thunderbird qui ne sait plus se connecter à Google... ;)


Plus d'infos ici : https://support.google.com/mail/answer/185833?hl=fr

Attention ! Google ne donne le mot de passe qu'une seule fois. Si il est perdu, il faut en recréer un autre...