...

bugg suite changement de serveur

Démarré par fonfonsd, 14 Mai 2022 à 22:11:20

« précédent - suivant »

fonfonsd

Bonjour, à tous
Je reprends mon forum SMF en main (du moins j'essaye), je commence par changer de serveur. Par contre j'ai du faire une erreur quelque part, j'ai tout installé les dossier FTP puis ma sauvegarde de base de données.

Suite à l'installation quand je vais sur fjassociation.fr/repair_settings.php j'ai cela comme erreur

Code
[b]Deprecated[/b]: Required parameter $table follows optional parameter $method in [b]/htdocs/Sources/Subs-Db-mysql.php[/b] on line [b]630[/b]

[b]Deprecated[/b]: Required parameter $columns follows optional parameter $method in [b]/htdocs/Sources/Subs-Db-mysql.php[/b] on line [b]630[/b]

[b]Deprecated[/b]: Required parameter $data follows optional parameter $method in [b]/htdocs/Sources/Subs-Db-mysql.php[/b] on line [b]630[/b]

[b]Deprecated[/b]: Required parameter $keys follows optional parameter $method in [b]/htdocs/Sources/Subs-Db-mysql.php[/b] on line [b]630[/b]

[b]Deprecated[/b]: Required parameter $table follows optional parameter $method in [b]/htdocs/Sources/Subs-Db-mysql.php[/b] on line [b]1456[/b]

[b]Deprecated[/b]: Required parameter $columns follows optional parameter $method in [b]/htdocs/Sources/Subs-Db-mysql.php[/b] on line [b]1456[/b]

[b]Deprecated[/b]: Required parameter $data follows optional parameter $method in [b]/htdocs/Sources/Subs-Db-mysql.php[/b] on line [b]1456[/b]

[b]Deprecated[/b]: Required parameter $keys follows optional parameter $method in [b]/htdocs/Sources/Subs-Db-mysql.php[/b] on line [b]1456[/b]
[b] 
[/b]

merci

maximus23

Bonjour,

Tu es certain d'avoir une sauvegarde complète en bonne et due forme de ta Base de données ?

Les paramètres dans le settings sont mis à jour pour la nouvelle base de données ?

:)
Amitiés et à Bientôt.
Have a Nice Day.
Developer Aestan Tray Menu for WampServer

fonfonsd


bonjour

oui je suis sûr, j'ai la version
db_fonfonsd2-complete_2022-05-11.sql.gz
et
db_fonfonsd2-complete_2022-05-11.sql

je suis sur car j'ai déjà fait une installation complète qui à marché.   suite à une mégarde j'ai tout planté, j'ai donc re commencé et c'est la que cela bloque.

La seule différence entre les 2 et que la première fois, je suis passé par fileZilla pour mettre mes dossiers FTP, et la seconde par leur gestionnaire de fichier. J'ai noté une différence et que sur FileZilla je tombe évidement sur la racine / de l'hébergement, alors que avec leur gestionnaire de fichiers je tombe comme racine sur htdocs/  ils m'ont dit que c'est la même chose.

Effectivement quand je me connecte maintenant avec FileZilla je tombe directement sur les dossiers smf

Je joins photo de mysql

PS : cela me fait plaisir de rediscuter avec toi maximus23

maximus23

Bonjour,

Vérifie la version PHP qui est active sur ton hébergement.

Je ne sais pas quel est ta version actuelle de Smf mais tu dois remettre la même pour que cela tourne correctement puis mettre l'upgrade.

Selon ta version de Smf la version de PHP diffère.

:)
Amitiés et à Bientôt.
Have a Nice Day.
Developer Aestan Tray Menu for WampServer

fonfonsd

bonjour
merci pour ton aide.
J'y avais déjà pensé a l'upgrade mais j'ai peur que mon thème fonctionne plus et cela m'embête de tout refaire le thème.

sinon je regarderai pour la version, mais ce qui est bizarre c'est que le site fonctionnait bien jeudi. J'ai fais une connerie je me suis cru plus intelligent que tout le monde, et je travaillé en même temps sur l'installation d'un autre site, et c'est là que j'ai fais la boulette j'ai fais une installation de wordpress  par dessus mon forum.

J'ai donc tout effacé et re installé et là c'est là que j'ai eu mon souci

PS je viens de vérifier je suis en version 8  pour le forum je dois être de mémoire en 2.01

fonfonsd

bonsoir
j'ai modifié la version PHP de mon hebergement j'ai mis 7.4
suite à cela je n'ai plus toute les lignes d'erreur sauf que à première vue repair-setting n'arrive pas à se connecter sur la base de données j'ai
Code
Some settings are not being shown because the database connection information is incorrect.
Check your database login details, table prefix and that the database actually contains your SMF tables

Pourtant je suis sur de se que j'ai mis sur le fichier Settings-php
j'ai bien mis la bonne base bon identifiant et bon mot de passe

maximus23

Bonjour,

Smf en 2.0.1 il ne fonctionnera qu'en PHP 5.6.x. On commence à utiliser le Php 7.0 à partir de Smf 2.0.16.

:)
Amitiés et à Bientôt.
Have a Nice Day.
Developer Aestan Tray Menu for WampServer

fonfonsd

#7
de mémoire après reflexion je dois etre en 2.017

je pense a un problème de connection à la base de données, d'après le message d'erreur mis ci dessus

maximus23

Bonsoir,

Oui cela est bien indiqué. Tu sais te connecter avec ton phpmyadmin ?

Vérifie bien ton Settings.

Si cela perdure repars à zéro effaces la base et l'utilisateur et recommence le tout avec des nouveaux paramètres.

:)
Amitiés et à Bientôt.
Have a Nice Day.
Developer Aestan Tray Menu for WampServer

fonfonsd

bonjour
aucun souci pour moi pour me connecter sur ma base de données avec mysql

installation refaite mot de passe base de données changé et toujours pareil