...

Smf et Php 7.2

Démarré par alexetgus, 10 Avril 2019 à 17:51:47

« précédent - suivant »

alexetgus

Toujours pas de nouvelles pour SMF et PHP 7.2, voir 7.3 ?

maximus23

Bonjour,

Non la seule option disponible pour le moment est la mise en application du module PHP 7.2+ Compatibility

Très bon Module pour le mail aussi c'est Zhen Mailer

:)
Amitiés et à Bientôt.
Have a Nice Day.
Developer Aestan Tray Menu for WampServer

alexetgus

Je préférerais une version officielle, vois-tu ? :)

Goupilop

02 Mars 2020 à 09:28:08 #3 Dernière édition: 02 Mars 2020 à 09:34:26 par Goupilop »
    Bonjour,

    Ben voilà j'ai le prestataire qui m'indique qu'au 1er Avril 2020:

"Attention: Afin de suivre le cycle de vie des versions PHP, à compter du 1er avril 2020, l'ensemble des sites utilisant PHP 5.4 et 5.5 seront migrés vers PHP 5.6. Les sites utilisant PHP 7.0 et 7.1 seront migrés vers PHP 7.2. Vous pouvez anticiper dés maintenant en basculant vous même la version de PHP. Vous trouverez plus d'informations sur notre blog"

---------------------------------------------------------

Donc d'après SMF 2.0.17:

Changements notables dans 2.0.16 et 2.0.17
  • Prise en charge de la politique de confidentialité en plus de l'accord d'enregistrement
  • Bascule de conformité GDPR dans les fonctionnalités principales
L'activation de ceci configure plusieurs paramètres et nouvelles fonctionnalités pour se conformer au RGPD, notamment:
    • Obliger les membres à accepter la politique de confidentialité actuelle afin d'utiliser le forum
    • Demander lors de l'inscription si le nouveau membre souhaite recevoir des annonces par e-mail
    • Activation des liens de désabonnement basés sur des jetons dans les e-mails afin que les membres puissent se désinscrire sans se connecter
    • Permettre aux membres de télécharger une copie des informations de leur profil
    • Ajuster le comportement d'un certain nombre d'autres fonctionnalités de manière mineure si nécessaire
[/li]
[li]Prise en charge de PHP 7.2[/li]
[li]Amélioration des hachages de sécurité pour le proxy d'image[/li]
[li]Amélioration de la sécurité du cookie de connexion[/li]
[li]Assortiment d'autres améliorations de sécurité[/li]
[li]Diverses améliorations à la fois pour l'installateur et pour la mise à niveau[/li]
[/list]
Veuillez consulter le changelog pour plus d'informations.

---------------------------------------------------------------

Je vais passé à la 7.2.28 pour voir

Goupilop

02 Mars 2020 à 10:07:08 #4 Dernière édition: 02 Mars 2020 à 10:09:04 par Goupilop »
Après passage au PHP 7.2.28 pas de souci apparemment sauf le paquet max_upload qui m'indique:


AH01071: Got error 'PHP message: PHP Warning: count(): Parameter must be an array or an object that implements Countable in /var/z.fr/httpdocs/smf/MyCollaboration/max_upload/max_upl_img.php on line 481\nPHP message: PHP Warning: count(): Parameter must be an array or an object that implements Countable in /var/z.fr/httpdocs/smf/MyCollaboration/max_upload/max_upl_img.php on line 484\nPHP message: PHP Warning: count(): Parameter must be an array or an object that implements Countable in /var/z.fr/httpdocs/smf/MyCollaboration/max_upload/max_upl_img.php on line 484\n', referer: https://z.fr/index.php?topic=424.15

La version étant la 3.4 de maxupload

maximus23

Bonjour,

C'est normal il faut avoir la dernière version 3.5 pour le Php 7.2 car il y a pas mal de temps que la fonction Count a été remplacée.

:)
Amitiés et à Bientôt.
Have a Nice Day.
Developer Aestan Tray Menu for WampServer

Goupilop

Merci max pour l'explication :)