...

Mise à jour pour les annexes Wampserver

Démarré par maximus23, 03 Août 2017 à 12:08:15

« précédent - suivant »

Otomatic

Bonjour,

- Apache 2.4.50 32bit
https://wampserver.aviatechno.net/files/apache/wampserver3_x86_addon_apache2.4.50.exe
- Apache 2.4.50 64bit
https://wampserver.aviatechno.net/files/apache/wampserver3_x64_addon_apache2.4.50.exe

Important: Avant d'installer Apache 2.4.50, la mise à jour Wampserver 3.2.5 ou plus est nécessaire. Il est également indispensable d'avoir préalablement installé les Visual C++ Redistribuable Packages VC 2015-2019 (VS16) 14.29.30133 ou plus.

Otomatic

Bonsoir,

Correction des failles de sécurité dans la version 2.4.50, voir https://httpd.apache.org/security/vulnerabilities_24.html .

! !! Si vous utilisez le serveur HTTP Apache 2.4.49 (uniquement cette version), vous devez effectuer une mise à jour vers la 2.4.50 dès maintenant en raison de CVE-2021-41773, une méchante vulnérabilité 0-day de traversée de chemin (path traversal vulnerability)

Otomatic

Bonjour,

- Apache 2.4.51 32bit
https://wampserver.aviatechno.net/files/apache/wampserver3_x86_addon_apache2.4.51.exe
- Apache 2.4.51 64bit
https://wampserver.aviatechno.net/files/apache/wampserver3_x64_addon_apache2.4.51.exe

Important: Avant d'installer Apache 2.4.51, la mise à jour Wampserver 3.2.5 ou plus est nécessaire. Il est également indispensable d'avoir préalablement installé les Visual C++ Redistribuable Packages VC 2015-2019 (VS16) 14.29.30133 ou plus.

Correction d'une vulnérabilité de sécurité critique dans la version 2.4.49, voir https://httpd.apache.org/security/vulnerabilities_24.html .

Note : Malheureusement, il a été constaté que la correction du problème de traversée de fichiers dans la version 2.4.50 était incomplète et pouvait être contournée.
Si vous utilisez le serveur HTTP Apache 2.4.49 ou 2.4.50 (uniquement ces versions), vous devez effectuer une mise à jour vers la version 2.4.51 dès maintenant en raison de CVE-2021-42013, une vulnérabilité 0-day de traversée de chemin.

Otomatic





JCFM

Bonjour, Oto , bonjour à tous !
Cette version est-elle vraiment utile, depuis la 7.4.xxxx est maintenant la 8.xxx
Les hébergeurs sont pratiquement tous avec la 7.4.xxx, celle qu'ils recommandent et, bien entendu, la 7.8 qui est proposée, mais j'ai encore des problèmes avec.
Merci encore pour le suivit de Wamp.
Cordialement.
JC
JCFM

Otomatic

Bonjour,

Mise à jour de « sécurité » pour la branche 7.3. Voir fichier news.txt.

Ça existe, donc je fais les "addons", ça peut être utile à quelques-uns.

Pour l'anecdote, pour quelqu'un qui avait besoin de migrer vers un PHP plus récent, je viens de compiler un addon PHP 5.5.12 qui tourne parfaitement sous Wampserver 3.2.6 (Version à venir avec PHP 8.1.0).

Bon dimanche :)



Otomatic

Bonjour,

VC17 Paquetages - VC 2015-2022 14.30.30704
Visual C++ Redistributable Packages for Visual Studio 2015-2022 x86
Visual C++ Redistributable Packages for Visual Studio 2015-2022 x64
VC 2015-2022 (VC17) est retrocompatible avec VC 2015 (VC14), VC 2017 (VC15) et VC 2019 (VC16). Cela signifie qu'un module VC14, VC15 ou VC16 peut être utilisé avec les binaires VC17. De par cette compatibilité, le numéro de version de Redistributable est 14.3x.xx et après l'installation, les paquetages Redistribuable VC2015 (VC14), VC2017 (VC15) et VC2019 (VC16) sont éventuellement supprimés mais vous pourrez toujours utiliser VC14, VC15 et VC16.

- Vérifier que tous les paquetages VC++ sont bien installés et avec les dernières versions.
Pour ce faire, utilisez l'outil :
Vérifications paquetages VC installés
N'utilisez pas une ancienne version de l'outil que vous auriez déjà téléchargé. Télécharger toujours la dernière version juste avant de l'utiliser.
Pour télécharger les paquetages manquants, ne vous fiez pas aux liens Microsoft, ils ne sont pas toujours fiables, télécharger les paquetages sur http://wampserver.aviatechno.net dans la section Visual C++ Redistribuable Packages

Otomatic

Bonjour,

- Wampserver 3.2.6 installeurs complets 32 et 64 bit
Apache 2.4.51 - PHP 5.6.40/7.4.26/8.0.13/8.1.0 - MySQL 5.7.36|[8.0.27 pour 64 bit] - MariaDB 10.5.13|10.6.5
PhpMyAdmin 4.9.7/5.1.1 - Adminer 4.8.1 - PhpSysInfo 3.3.4
En Option : PHP 7.0.33/7.1.33/7.2.34/7.3.30
- Wampserver 3.2.6 32bit
https://wampserver.aviatechno.net/files/install/wampserver3.2.6_x86.exe
- Wampserver 3.2.6 64bit
https://wampserver.aviatechno.net/files/install/wampserver3.2.6_x64.exe

- Wampserver update 3.2.6
Ne met à jour que "Wampmanager", n'ajoute aucune version Apache PHP, MySQL ou MariaDB. C'est une mise à jour cumulative. Il n'y a pas lieu d'appliquer les anciennes mises à jour 3.0.1 à 3.2.5 avant d'appliquer 3.2.6. Il n'y aura pas de changement de vos paramètres et versions Apache, PHP, MySQL, MariaDB utilisées ; vos sites et bases de données locales ne seront pas affectés. Cette mise à jour est nécessaire pour pouvoir installer les prochains addons Apache, PHP, MySQL ou MariaDB
https://wampserver.aviatechno.net/files/updates/wampserver3_x86_x64_update3.2.6.exe

---- Évolutions Wampserver 3.2.6
- Support PHP 8.1
- Amélioration default_file services MySQL et MariaDB
- Support de Graceful Restart Apache
- Redémarrage Wampserver en un clic
- Affichage date/heure du dernier démarrage
- Comparaison des configurations Apache
- Possibilité de copier la configuration Apache lors du changement de version : LoadModule - Include - Listen port - httpd-vhosts.conf - httpd-ssl.conf - openssl.cnf - dossier apache2.4.xx\conf\Certs\ si existant
- Possibilité de restaurer httpd.conf et httpd-vhosts.conf sauvegardés lors de l'installation d'une version Apache
- Amélioration affichage fenêtres de commande
- Possibilité de vérifier les mises à jour Wampserver, Aestan Tray Menu, Apache, PHP, MySQL, MariaDB, etc.

- PHP 8.1.0 32bit
https://wampserver.aviatechno.net/files/php/wampserver3_x86_addon_php8.1.0.exe
- PHP 8.1.0 64bit
https://wampserver.aviatechno.net/files/php/wampserver3_x64_addon_php8.1.0.exe

JCFM

Bonsoir, Oto
Installation complète, impeccable comme d'habitude, m'a semblé plus rapide.
Bravo
JCFM

maximus23

Bonjour,

Je confirme que tout est Ok pour Windows 11.

:)
Amitiés et à Bientôt.
Have a Nice Day.
Developer Aestan Tray Menu for WampServer