...

Test Module Max Image Management

Démarré par maximus23, 04 Février 2018 à 16:41:34

« précédent - suivant »

alexetgus

23 Février 2018 à 18:05:55 #15 Dernière édition: 23 Février 2018 à 18:07:52 par alexetgus »
Citation de: maximus23 le 23 Février 2018 à 03:12:41Bonsoir,

Oui j'ai fait des tests sur le serveur :)

Non c'est pas le popup c'est le module image quand tu ouvres par exemple avec les derniers fichiers ou que tu mets le bouton texte puis que tu fais non ou que tu fermes les dernières images la frame se redimensionne toute seule elle ne reste plus ouverte complètement avec du vide en dessous ce qui repoussait les boutons pour poster plus bas :)



Ah ça !
Oui, ça marche. Ca se redimensionne selon le contenu.


PS
Je vois que je ne suis pas le seul à mettre couché tard dans la nuit, ou plutôt de bonne heure ce matin. :)

maximus23

Bonjour,

Bon c'est pas déjà trop mal on avance bien je vais récapituler tout cela et voir ce que je vais faire car en manque d'inspiration pour le moment. C'est le froid qui congèle mes neurones :) :)
Amitiés et à Bientôt.
Have a Nice Day.

Goupilop


Goupilop

23 Février 2018 à 19:07:42 #18 Dernière édition: 23 Février 2018 à 19:09:20 par Goupilop »
Citation de: maximus23 le 21 Février 2018 à 21:42:10Bonsoir,

En passant aussi @Goupilop pas eu de problèmes de navigateurs avec w10 après la mise à jour ?
Bonsoir Max, désolé pour le retard de réponse...

Non j'ai aucun problème avec le dernière version de Windows 10 Pro (Windows 10 Pro Couche d'abstraction matérielle    Version = "10.0.16299.248") x64
Navigateur Firefox v 58.0.2
Bonne soirée

Goupil





Philippe


Philippe

Bonjour
Je teste à mon tour et j'ai une petite remarque.
Après avoir sélectionné le fichier sur son DD avec Parcourir, on clique sur Envoyer et l'image est transférée sur le serveur.
Ma remarque est : il ne se passe rien à l'écran pendant tout le temps du transfert vers le serveur. Je fais parti des gens qui ont une connexion assez lente et donc ce temps est assez long. Cela va probablement inciter ces personnes à cliquer plusieurs fois sur Envoyer sans résultat apparent.

Est ce qu'il serait possible d'avoir un sablier ou un barre-graphe ou qq chose de ce genre pour indiquer à l'utilisateur que le transfert est en train de se faire?
 
Pas obligatoire mais je pense qu'il y a encore pas mal de personnes qui ont une connexion lente.  



Goupilop

24 Février 2018 à 13:48:22 #21 Dernière édition: 24 Février 2018 à 13:50:15 par Goupilop »
Bonjour,

Pour info:
Lorsque l'on enregistre (enregistrer l'image sous) l'image sur le PC celle-ci est nommé blank avec 1x1 pixel ?
Le détail de l'image est inexistant également (notamment la capacité) ?

maximus23

Citation de: phil185 le 24 Février 2018 à 11:00:28Est ce qu'il serait possible d'avoir un sablier ou un barre-graphe ou qq chose de ce genre pour indiquer à l'utilisateur que le transfert est en train de se faire?

Bonjour,

Il y en a une et logiquement tu devrais la voir. Tu cliques sur le bouton envoyer sans rien faire d'autre pour voir si tu as bien la barre de traitement des fichiers qui va apparaître en dessous des disquettes :) Dis moi si tu l'as bien ?

Citation de: Goupilop le 24 Février 2018 à 13:48:22Lorsque l'on enregistre (enregistrer l'image sous) l'image sur le PC celle-ci est nommé blank avec 1x1 pixel ?
Le détail de l'image est inexistant également (notamment la capacité) ?

Ici oui il y a une "protection" que j'ai mise. J'avais fait cela pour passer mon temps mais sur la version du module il n'y a pas ce remplacement cela n'a rien avoir. Si tu veux savoir ce qu'il en est pour les images tu as toutes les infos dans l'historique de tes uploads.

:)


Amitiés et à Bientôt.
Have a Nice Day.

Goupilop

Bonjour,
Ok MAx, mais bon tu sais que l'on peux toujours détourner ta protection :D ;D  Mais j'ai noté, c'est très bien dans ce sens :)
Merci
Bon Dimanche :D

Philippe

Citation de: maximus23 le 24 Février 2018 à 17:49:51
Citation de: phil185 le 24 Février 2018 à 11:00:28Est ce qu'il serait possible d'avoir un sablier ou un barre-graphe ou qq chose de ce genre pour indiquer à l'utilisateur que le transfert est en train de se faire?

Bonjour,

Il y en a une et logiquement tu devrais la voir. Tu cliques sur le bouton envoyer sans rien faire d'autre pour voir si tu as bien la barre de traitement des fichiers qui va apparaître en dessous des disquettes :) Dis moi si tu l'as bien ?


Elle apparait bien mais seulement un court instant

maximus23

Bonjour,

Bon avancement en progrès de la version finale. J'ai adopté un procédé de recherche full text pour la gestion administrative des fichiers.

Cela permet de traiter un million d'enregistrement en une seconde.

Pour la version 2.1 les index sont déjà définis mais pour la version 2.0 de Smf il faudra qu'ils soient créés faute de quoi la gestion des fichiers ne sera pas activée.

Cela se fera sur simple demande par test de validation sur l'index si il existe ou pas et si vous voulez le créer ou pas.

Il vous sera aussi dit de faire un backup de votre base de données avant toutes modifications comme c'est le cas en général.

Voilà pour les dernières infos.

:)
Amitiés et à Bientôt.
Have a Nice Day.

maximus23

Bonjour,

Voilà un test effectué avec la gestion des fichiers. J'ai retiré les points de traitements pour avoir une globalisation du benchmark avec toutes les requêtes.

Je trouve cela pas trop mal.



:)
Amitiés et à Bientôt.
Have a Nice Day.

Goupilop

Bonsoir max,

Là tu tape dans le dur ;)  me languis de la version finale :D
Merci pour ton dévouement, bon travail ;)
Bonne soirée

Goupil

maximus23

Test version 4.4 pour Smf 2.1



Merci de tester et de reporter les bugs c'est la même chose que la 3.4 pour Smf 2.0.15.

:)
Amitiés et à Bientôt.
Have a Nice Day.

alexetgus

05 Mars 2018 à 13:31:25 #29 Dernière édition: 05 Mars 2018 à 13:35:23 par alexetgus »
Je repasse et je te dis. J'ai pas fini ma tournée des popotes et ça va être l'heure de "Scènes de ménage" sur la 6. :-[
;)


Ne le prends pas mal, mais je ne sais pas si j'installerai ta nouvelle version. Ou alors il faudra que je la modifie.
Je n'aime pas l'historique et les dernières images, c'est confus.

Pour chaque truc, tu devrais créer un paramètre admin "Activer / Désactiver", ce serait bien mieux. :)

Parce-que mine de rien, c'est en train de devenir une véritable usine à gaz ce mod !
Il faut penser aussi à la sécurité avec tout ce JS. Une faille XSS et de l'injection de code, ça va vite. :-\

Il y a aussi un truc à régler d'urgence, c'est cette impression de boucle sans fin dès qu'on répond à un message et qui charge le CPU quel que soit son type ou sa puissance. Je t'en avais déjà parlé. Là, ça commence à se voir avec Chrome qui rame sur les réponses.
Je n'ai pas regardé, mais je vais être obligé de la faire. Je déteste que mes membres aient des soucis. :(