...

Mise à jour d'un forum de 1.0.17 vers 2.1RC3

Démarré par srafie, 22 Décembre 2020 à 06:52:18

« précédent - suivant »

srafie

Bonjour,
mon forum est sous 2.0.17, il est en production et donc, peuplé de sujets, images, membres etc.
J'ai alors créé un clone dans un dossier test et je souhaiterai mettre à jour ce dernier en 2.1RC3 avant de basculer le forum en prod.
Quand je télécharge le paquet large upgrade pour l'installer, j'ai un retour d'erreur comme quoi l'archive est vide (voire capture d'écran.
Je me suis alors dit, que cette version ne supportait pas, peut-être une mise à jour à partir de l'interface admin.
Merci de m'aider en m'indiquant la méthode à suivre pour faire cette mise à jour, je commence à avoir pas mal de topics intéressants et des membres qui s'inscrivent et je ne voudrais pas les perdre.

Encore merci

maximus23

Bonjour,

Cela ne se fait pas via le gestionnaire de paquets il faut mettre tous les fichiers et lancer upgrade.php et suivre les instructions.

Toujours faire de sérieux backup avant de faire ce genre de chose.

:)
Amitiés et à Bientôt.
Have a Nice Day.
Developer Aestan Tray Menu for WampServer

srafie

22 Décembre 2020 à 19:07:08 #2 Dernière édition: 22 Décembre 2020 à 19:20:14 par srafie »
Juste dans le doute, j'ai tout mis en 777 (fichiers et dossiers) pour les permissions ;) :)

srafie

22 Décembre 2020 à 19:24:39 #3 Dernière édition: 22 Décembre 2020 à 19:36:04 par srafie »
Citation de: maximus23 le 22 Décembre 2020 à 10:52:18Cela ne se fait pas via le gestionnaire de paquets il faut mettre tous les fichiers et lancer upgrade.php et suivre les instructions.
Bonsoir,

J'ai dezippé le fichier smf_2-1-rc3_upgrade.zip dans un dossier portant le même nom dans le dossier Packages et j'ai lancé le fichier upgrade.php à partir de l'url monforum.com/test/Packages/smf_2-1-rc3_upgrade/upgrade.php

là j'ai une erreur 403 (voir copie d'écran)

Une idée svp?


Edit: j'ai ensuite déplacé le dossier "smf_2-1-rc3_upgrade"  à la racine du site de test et j'ai eu cette fois-ci l'erreur suivante:
"Settings.php was not found where it was expected: /home/digitalj/public_html/forumfibre/forum-test/smf_2-1-rc3_upgrade/Settings.php! Make sure you have uploaded ALL files from the upgrade package to your forum's root directory. The upgrader cannot continue."
Je ne sais plus quoi faire ;) :)

srafie

Bon, je réponds à moi-même espérant que ça servira aux autres membres:

En fait, la solution est de copier et remplacer tous les fichiers et dossiers de la mise à jour dans le dossier racine et ensuite exécuter le fichier upgrade.php.

Je continue à parcourir et tester cette version sur le forum de test avant de décider de la passer sur le forum de production.

Je note quelques soucis, comme l'impossibilité de s'inscrire. je posterai ce bug, si je ne trouve pas de réponse ici.

Merci, Joyeux Noël à tous et Bonne année 2021 :) :)

maximus23

Bonjour,

Oui tout est expliqué dans les messages de mise à jour.

Pour tes inscriptions il faut remettre les paramètres dans l'Admin section Membres.

Merci et bonne fêtes de fin d'année également.

:)
Amitiés et à Bientôt.
Have a Nice Day.
Developer Aestan Tray Menu for WampServer

Goupilop

Bonjour,

Merci srafie pour les infos sur l'installation de cette version 2.1RC3 (ainsi K max pour les retours).
Vais pas me prendre la tête pour les fêtes, vais attendre la sortie officielle
Bon Noël :)