...

Mysqldumper

Démarré par maximus23, 07 Avril 2019 à 23:25:37

« précédent - suivant »

maximus23

Bonjour,

Voici une version de Mysqldumper compatible avec le PHP 7.1.x.

Gestion base MySQL et MariaDb.

Pour l'installer le mettre dans le répertoire apps de WampServer et créer un Alias.

Toute la documentation se trouve Ici

Version pour Php jusque 7.2 sur GitHub Ici

Il faut regarder les modifications et les appliquer le cas échéant sur la version de base.

:)
Amitiés et à Bientôt.
Have a Nice Day.
Developer Aestan Tray Menu for WampServer

Otomatic

Bonjour,

Mysqldumper fonctionne toujours avec :
- Apache 2.4.41
- MySQL 8.0.17
- MariaDB 10.4.7
- PHP 7.4.0 RC1
Le tout en 64 bit.

Goupilop

Hello,

Merci pour l'info

Otomatic

Bonjour,

Mysqldumper fonctionne toujours avec :
- Apache 2.4.41
- MySQL 8.0.18
- MariaDB 10.4.11
- PHP 7.4.0
Le tout en 64 bit.

Otomatic

Bonjour,

Mysqldumper fonctionne toujours avec :
- Apache 2.4.41
- MySQL 8.0.19
- MariaDB 10.4.12
- PHP 7.4.4
Le tout en 64 bit.


J'aurais du mal à m'en passer :)

Otomatic

onjour,

Mysqldumper fonctionne toujours avec :
- Apache 2.4.43
- MySQL 8.0.21
- MariaDB 10.4.13 & 10.5.4
- PHP 7.4.8
Le tout en 64 bit.

J'aurais encore du mal à m'en passer ;)

Otomatic

Bonjour,

Mysqldumper fonctionne toujours avec :
- Apache 2.4.46
- MySQL 8.0.22
- MariaDB 10.5.8
- PHP 8.0.0
Le tout en 64 bit.
Nettement plus rapide avec PHP 8.0.0 qu'avec PHP 7.4.13
Même restauration : PHP 7.4.13 3 min 25s - PHP 8.0.0  2 min 10s

J'aurais encore du mal à m'en passer ;)

Goupilop

Bonjour,

Le mec qui à développé Mysqldumper est un pro de l'info... Chapeau bas et merci à lui surtout :)

Otomatic

Mysqldumper fonctionne toujours avec :
- Apache 2.4.48
- MySQL 8.0.25
- MariaDB 10.6.3
- PHP 8.0.8
Et même PHP 8.1.0alpha3
Le tout en 64 bit.

Nono25

Bonjour,
Utilisateur de Wampserver, j'ai eu connaissance de Mysqldumper via la signature d'otomatic dans le forum Wampserver.
Je cherche à l'installer sous Wampserver, via un virtual host.
Version Windows W10 Famille
Version Wampserver 3.2.5 64 bits
Version Apache 2.4.51
Version PHP 8.0.13
Version Mariadb 10.5.9

A l'installation j'ai une erreur "fonction get_magic_quote_gpc" que je corrige en forçant la config à 0;
J'ai ensuite une erreur lors de l'écriture du fichier config : la variable $tmp est vide, et donc la fonction implode plante.

J'ai téléchargé mysqldumper sur github/dsbmysqldumper, c'est la version 1.24.

Est-ce que j'ai téléchargé la bonne version? Si oui, comment l'installer proprement?

Merci d'avance pour vos réponses.

Cordialement

Otomatic

Bonjour,

La version qui tourne « toujours » est notée 1.24.5 chez moi. Je ne sais plus si le *.5 m'est personnel ou pas !
Je vais faire un zip de cette version "qui tourne" et mettrais un lien.

> fonction get_magic_quote_gpc
Dénote une version non modifiée, cette fonction est OBSOLÈTE à partir de PHP 7.4.0, et a été SUPPRIMÉE à partir de PHP 8.0.0. Mais peut-être que c'est moi qui est supprimé cet fonction !

Nono25

Bonjour à tous,
Merci Otomatic pour la réponse. J'attends le lien pour continuer mes tests.
Pour info, la version proposée sur github est 1.24.4. Elle fonctionne parfaitement sur Raspberry bullseye, avec PHP 7.4.25.
Bonne journée.
Cordialement

Otomatic

Bonjour,

Il y a d'autres modifications que j'avais effectuées pour le support PHP 8:
- remplacer each(..) par des strutures foreach(...)
- gérer la disparition de magic_quotes_gpc

Le zip est là : msd1.24.5_oto.zip

Nono25

Bonjour à tous,
Merci Otomatic pour l'archive.

J'ai eu deux petits soucis avec cette version :
- le fichier "config.php" est obligatoire, j'ai recopié celui de la version 1.24.4.
- une erreur de syntaxe dans le fichier "install.php", ligne 316 : les paramètres de la fonction implode() sont inversés, j'ai remplacé implode($tmp,"") par implode("",$tmp)

Maintenant tout fonctionne bien.

Merci pour l'aide apportée et à bientôt.

Otomatic

Bonjour,

Je n'utilise que Exporter et Importer, ce qui fait qu'il peut y avoir encore des erreurs en utilisant les autres possibilités.

Et, comme j'ai toujours modifié « sur place », la procédure d'installation est passée à l'as !